Forum Francophone Home Assistant

Camera Sricam

Bonjour a tous
j’essaye d’intégrer une caméra SRICAM SP005 dans mon configuration.yaml j’ai mis
camera:
platform: ffmpeg
name: my camera
input: rtsp://192.16X.XX.XX:554/onvif1

dans mon tableau de bord j’ai ajouté une carte POINT DE VUE IMAGE en mode AUTO
mais je n’arrive pas a avoir le live de la camera j’ai une image toutes les 10 secondes
Si je met en mode LIVE j’ai une fenêtre grisée
Il y a écrit aussi EN VEILLE
Si je clique sur le fenêtre il y a un écran avec une roue qui tourne a l’infini et c’est écrit en haut RELOAD STREAM

Quelqu’un aurait une idée ?
Merci de vos réponses

bonjour pourquoi tu ne passe pas par l’integration onvif?
configuration ----> integration ----> ajouter une integration ----> onvif

stephane
sinon en manuel:

voici mon intégration:

#############################
########  cameras  ##########
#############################
camera:
  - platform: ffmpeg
    name: camera_entréé
    input: !secret rstp1

pour le rstp j’utilise le logiciel : onvif device manageur.
il vas trouver ta cam onvif et t’aura ton rstp à copier coller doc en anglais au même endroit
Sans titre

Bonjour merci pour vos reponses
J’ai essayé onvif mais je ne sais pas quoi mettre dans les identifiants il ne prend pas les miens
et je ne comprend pas le INPUT !secret rstp1 il faut creer un fichier ? ou je met mon lien rstp ?
Merci encore

oui le !secret tu remplace par ton liens. rstp…
est tu sure de ton liens rstp?
as tu essayer login admin et pas de mot de passe? pour l’intégration
onvif c’est plutôt très ouvert :slight_smile:

Steffleur
voici une capture de onvif device manager
je n’ai rentrer aucun identifiant dedans
image

et pour info ce n’est pas onvif que j’avais essayé mais motion eyes oups :frowning:

je vois que dans ta photo c’est media1 a la fin du lien moi c’est onvif1

voici mon configuration.yaml
camera:

  • platform: ffmpeg
    name: My Camera
    input: rtsp://192.168.X.XX:554/onvif1

je suis sur rapsberry pi3 et l’image est toujours saccadée

Ok donc tu as le bon rstp
As tu essayé l’intégration onvif avec admin et pas de mot de passe
Ça te donne deux flux normalement
Le saccadé 10 sec c’est normal lorsque tu click dessus ça doit être fluide

Avec un décalage de quelques secondes

salut Steffleur
je viens d’integrer ONVIF avec admin et pas de passe j’ai bien 2 cameras une MAINSTREAM et une SUBSTREAM mais toujours pas de live quand je clique dessus cela tourne en rond.
Peut etre c’est la carte dans le tableau de bord qui va pas moi je chois COUP D’OEIL IMAGE avec ffmpeg -1 et UDP dans reglage
PS: pour info je suis revenu a l’origine usine camera j’ai essayé avec mot de passe par defaut meme chose PAS DE LIVE

Bonjour,
j’ai exactement le même soucis
as tu trouvé une solution ?

merci

Bonsoir Christian ma camera donne juste une image mais pas de live.Du coup j’avais besoin d’une camera exterieure et le flux vidéo est bien en live.Donc pour mon cas je pense que la Sircam n’est pas compatible avec le flux video de Home Assistant…

Bonjour Bruno.
Oui j’ai le même problème sur la caméra sricam.

Il doit bien avoir une solution mais cela va être encore chronophage…
Je débute avec home assistant ,je ne sais qu’elle camera choisir ? Onvif ou pas ?

Bonjour
voici le lien de ma caméra je la voit bien en live sans sous dans home assistant.La meme marque fait des camera interieur aussi.
Pour ma part pour la Sircam je n’ai pas trouvé de solution j’ai essayé le onvif le rstp enfin tout se que l’on peut sur home.Par contre dans vlc le flux video fonction.Je crois avoir vu que cela ne fonctionne pas car la Sircam (mon modele ) n’a pas de serveur interne

Le lien:


Bonne journée

C’est une caméra onvif ?
Merci

Oui elle est en integration onvif sur Home assistant