Forum Francophone Home Assistant

Carte SD corrompu suite coupure de courant sur PI 4B

Bonsoir a tous,
Je sollicite votre aide car malgré une recherche sur le forum je ne trouve pas de solution a mon problème.

Ma carte SD semble corrompu, impossible de démarrer OS home assistant .
j’ai effectué une nouvelle installation sur un SSD cette fois, mais j’aimerais recuperer les fichiers de sauvegarde présent sur ma carte SD.
Quelqu’un pourait il m’indiquer leur nom et ou trouver ceux ci .
J’ai installé UBUNTU sur mon pc portable et j’arrive a lire le contenu de la carte SD sans problème.

Merci d’avance pour votre aide.

Jimmy

Bonsoir
Normalement tu as un dossier backup
Sur ta carte sd corrompu
Stefan

Oui, s’il n’est pas corrompu il doit y avoir le dossier /backup…

Pour mémoire, une install HA sur RPI avec une carte SD, ça tient entre 1 et deux ans et c’est parfaitement viable, à condition :

  • Carte SD de type A2
  • Sauvegarde quotidienne externe (intégration Google Drive par exemple).

Disposer en permanence d’une carte SD de secours : l’install de HA + restauration ça se fait en 5/10 minutes max et ça repart pour 1 ou 2 ans…

Et ne pas perdre de vue qu’une installation de type SSD ne dispense pas d’une sauvegarde externe, le SSD tiendra plus longtemps et sera plus rapide, mais pas infaillible :wink:

Bonne chance avec ta SD. Il existe des outils de recovery, généralement dédiés au photos mais ça peut t’aider.

Bonjour et merci pour votre réponse,
J’obtiens une Erreur "Mounting/Dev"quand je cherche a monter la partition Hassos-data .
le Dossiers Backup doit s’y trouver je pense
Je vais essayer en recovery avec un outils en esperant ne rien perdre.

Jimmy

Bonjour @Jimmy, @steffleur et @Canaletto,

J’ai un problème similaire mais plus grave.

Comme expliqué ici j’avais une installation fonctionnelle Hassio sur Raspebrry Pi 4B et j’ai toujours remarqué des instabilités lors du redémarrage de mon Raspberry (je devais souvent couper et redémarrer l’alimentation plusieurs fois avant de récupérer un accès à Home Assistant). J’étais en phase de test mais une fois en prod je le monterai sur mon UPS.

Mais depuis mon dernier redémarrage impossible de récupérer Hassio sur ce Raspberry, j’ai à peu près tout essayé je pense :

  • Reboot de tous mes équipements de mon LAN : Livebox, Routeur (sur lequel se trouve le DNS local), NAS (sur lequel j’ai un reverse proxy).
  • Utilisation de différents supports pour Raspbian et Hassio : carte SD, différentes clés USB, différents hub USB, avec ou sans hub USB, sur les USB 2.0 ou 3.0.
  • Utilisation du wifi ou d’une liaison ethernet.
  • Installation de différentes versions de Raspbian (lite, 32 bits, 64 bits).

NB : j’ai eu une double coupure de courant (coupure > courant pendant 10 secondes > coupure > courant stable) avant cette dernière tentative.

J’ai essayé d’installer Hassio sur mon NAS mais la version supervised est non compatible sur Docker et mon NAS n’est pas compatible avec l’installation d’une machine Virtuelle : ces méthodes d’installation sont par ailleurs plus complexes et j’ai donc peur qu’elles demandent plus de maintenance à terme (compatibilité hardware/software notamment). Je ne trouve plus non plus de Raspberry Pi à acheter car ils sont en rupture partout. Bref je suis condamné à réussir …

Auriez-vous une idée ?

Comme dit plus haut, le RPI c’est bien, à la mode et ça peut être fiable. Mais pas sans inconvénients, et de plus en rupture ces temps ci…

Perso après avoir tourné sur un duo VM (ESX) et RPI3 j’a basculé sur un Odroid, un peu cher mais parfait (une VM ou un NAS ce n’est idéal pour de la domotique qui à mon sens doit être totalement indépendante).

Pour d’autres installations j’ai fait le choix du NUC. On en trouve sur ebay des NUC Intel d’occasion que les gens revendent car un peu poussif sous Windows mais qui seront parfaits pour HA (j’ai payé moins de 100 € pour un i3/8GB et 128 de SSD). Et c’est juste parfait pour un Home Assistant. Un Celeron est suffisant dans bien des cas.

Quelle cartes SD ou clés USB ? Toutes ne se valent pas, loin de là !!!

Merci pour ta réponse @Canaletto.

J’utilise des clés SanDisk SDCZ48-064G.

Une idée de ce qui pourrait clocher sur mon Raspberry et comment le réparer ?

Sinon je vais regarder du côté Odroid et NUC : quelles sont les différences avec les Rsapberry ? J’ai l’impression que c’est moins courant ? La communauté est-elle aussi riche ?

Merci pour ton aide,

Odroid c’est ce qui avait été proposé par Home Assistant comme étant l’idéal…

Un NUC c’est juste un PC compact et peu énergivore. Mais dans l’absolu n’importe quel petit PC peut faire le job, voire même un laptop un peu ancien… Ce qui compte c’est la fiabilité et une faible conso…

bonjour.
une idée car j’ai remarqué que certaines carte ou clef usb n’apprécier pas les multiple installation de hassio. (formatage +réinstallation ce plusieurs fois) même mes eemc)
je m’explique ayant plusieurs rpi pour test il m’arrive de devoir racheté une carte ou usb neuf pour faire des nouvelles installes. car sur certaines il y a quelques chose qui m’empêche de démarrer.
donc essaye avec un support neuf.ca te fera pas trop de frais

autre idée l’alimentation qui deviendrais défaillantes j’ai eut aussi souvent ce cas.

pour mon install en prod j’ai une aliment 15.3w rpi4 4giga disque dur ssd et clef zigbee sonoff zero soucis.
stef
et comme dit @Canaletto la box blue ou yellow sont normalement le recommandé.
voila ce sont que des pistes.
stefan

Tu peux dans ce cas faire un formatage bas niveau, il existe des utilitaires idoines :wink:

1 J'aime

Ok merci pour ce nouveau mot. Que je ne connaissais pas. « Idoines ».
C’est vraie que je réinstalle sans formaté avant je testerais et ferait un retour. J’ai 3 eemc briquer ça m’arrangerait bien

:wink:
J’avais sur un ancien PC un utilitaire interne HP qui faisait très bien le job. Si tu ne trouves pas je relancerait cette machine pour chercher.

bonjour

effectivement ca aide un bon formatage complet.
cool 2 eeMc qui revivent.
merci

Bonsoir,

J’étais sur le point d’acheter un NUC et par acquis de conscience j’ai branché mon Pi son un autre LAN (config très simple avec une Libeox et rien d’autre) et là … Miracle Home Assistant c’est lancé !

Du coup en rentrant à la maison j’ai testé de nouveau et cette fois-ci ça marchait : je n’ai pourtant absolument rien changé (ni support, ni config). Bref à n’y rien comprendre.

Premier truc que j’ai fait : monter mon Pi sur un UPS.

Premère tache de ma to do : regarder comment mettre un automatisme pour éteindre puis rebooter proprement le Pi et Hassio quand il ne reste plus que 5 min de reserves sur l’UPS.

En revanche aucune idée du problème et de comment il a été résolu …

Bonsoir,
Oui effectivement je vois bien un dossier BACKUP sur la partition corrompu.
je le visualise avec « PARTITION RECOVERY » malheureusement sans pouvoir sauvegarder car version payante naturellement.
Le dossier BACKUP contiens des archives avec extention en .Tar est-ce cela ?
Une idée pour recuperer le dossier ?

Bien amicalement

Jimmy

Bonsoir utilise ce a log gratuit sous windows recuva



Ou peut-être juste un livre cd sous linux ou usb

Stefan

Bonjour a tous,
J’ai reussi a recuperé la sauvegarde présente dans le dossier Backup.

J’ai utilisé Disk Drill en version essais, il est limité a 500 Mo, mais suffisant, ma sauvegarde faisant 180 Mo.
Dans mon cas je suis passer par une nouvelle installation est j’ai utilisé le fichier en .Tar au moment de la configuration.

Tout est rentrer dans l’ordre.

Un grand merci a tous pour vos conseils

Jimmy

1 J'aime