Forum Francophone Home Assistant

Comment Recuperer les infos mqtt

Bonjour
je souhaite récupérer les infos provenant d 'une station météo via mqtt. j’arrive a les faire apparaitre dans l’écoute mqtt mais je n’arrive pas a les faire ressortir pour un sensor.
Voici comment cela arrive sur mqtt

Merci

Bonjour
As tu installé le broker mqtt? Mosquito pour le plus connu. https://www.home-assistant.io/docs/mqtt/broker/

Si oui tu vas dans configuration puis appareil et la le nom de ton appareil
Tu auras tous les sensors
Stefan

@steffleur
Bonjour. Merci pour ta reponse.
j’ai bien installé le broker et j’arrive a l’ecouter ( limage de mon 1er post donne le resultat) mais je n’ai pas d’appareil qui apparait

Bonjour je pense qu’il n’est pas liée à ton broker et c’est pour cela qu’il ne remonte pas .
Tu crée tes sensor avec comme template ce que tu voie dans ton ecoute

Mais de mémoire, ( je n’ais qu’un Switch en mqtt) si ton émetteur est configurer
IP broker(hassio), login broker(utilisateur), et MDP broker( MDP utilisateur)
Ça remonte tout seul
Stefan

@steffleur
Bonjour et merci pour la reponse. je ne dois pas faire comme il faut car cela ne remonte toujours pas. dans le config. yaml je met ca
# Example configuration.yaml entry
sensor:

  • platform: mqtt
    state_topic: « nom de mon topic »

dans les options du courtier je met:
broker: mon ip de broker
port 1883
username rien
mot de passe rien

**Dans les options mqtt je ne change rien
Merci

1 J'aime

Tu dois mettre un user et un MDP, qui doivent être dans la config de mosquitto (addons)et dans configuration—> personne / utilisateur et dans ton client (station météo)
Sinon ça marchera pas
Dans l’ordre
1/ cree un utilisateur que pour mqtt
Redémarrer ha
2/ installer Addons mosquitto et dans configuration.yaml la ligne

mqtt:
  discovery: true

Redémarrer ha
3/ mettre l’utilisateur et le mot de pass dans Ton client
Redémarrer le client
Ça te mettra une notif nouvel appareil détecté
PS pas sur qu’il faut redémarrer ha deux fois.
Stefan

@steffleur
Bonjour ca ne fonctionne toujours pas :relieved:
je me demande si les infos sont considérées comme un sensor.
comment faire pour les déclarer comme un sensor ?
Voila ce que j’ai fait (plusieurs fois

  1. j’ai créé un utilisateur (non administrateur)

  2. j’ai redémarré

  3. j’ai installé l’addon mosquitto broker j’ai rajoute le login user et mot de passe avec mon user précédemment créé et j’ai démarré l’addon

  4. j’ai rajoute ligne de configuration yaml et j’ai redémarré

  5. l’intégration mqtt apparait avec une erreur de configuration. je rentre donc les infos du

  • broker 192.168.0.2

  • port 1883
    mdp utilisateur et utilisateur créé précédemment
    je relance