Forum Francophone Home Assistant

Esphome camera reste en veille

bonjour j’ai installé la version core-2021.7.1 / 5.4.83-v8 la dernière en date, et depuis lors je ne parviens plus à faire fonctionner le module ESP32 Camera pour une camera type Ai-Thinker.
cela fonctionnait avant le changement.
Maintenant elle reste toujours en veille, j’ai pourtant utilisé la même procédure d’intégration et fichier ayml.


Mais je constate que la programmation ou méthode n’est plus tout à fait pareil.
donc je pense que je dois renseigner un élément en plus.
J’ai suivis plusieurs méthode glanées sur les forums sans succès.
une idée?

en regardant dans : Configurations > journaux ; j’ai cela comme message :

Can’t connect to ESPHome API for camera (192.168.0.163): Timeout while waiting for API response!

13:41:13 – (ATTENTION) ESPHome - message survenu pour la première fois à 13:40:26 et apparu 2 fois

c’est quoi API ? c’est peut-être ça qui pose problème?

voici mon fichier camera.yaml
Dites-moi si cela est correcte
merci

esphome:
  name: camera
  platform: ESP32
  board: nodemcu-32s

# Enable logging
logger:

# Enable Home Assistant API
api:

ota:
  
wifi:
  ssid: !secret mon_ssid 
  password: !secret password_ssid
  manual_ip:
    static_ip: 192.168.0.163
    gateway: 10.0.0.1
    subnet: 255.255.255.0
 


esp32_camera:
  external_clock:
    pin: GPIO0
    frequency: 20MHz
  i2c_pins:
    sda: GPIO26
    scl: GPIO27
  data_pins: [GPIO5, GPIO18, GPIO19, GPIO21, GPIO36, GPIO39, GPIO34, GPIO35]
  vsync_pin: GPIO25
  href_pin: GPIO23
  pixel_clock_pin: GPIO22
  power_down_pin: GPIO32
  resolution: 800x600
  max_framerate: 8 fps

  # Image settings
  name: camera_01
  
text_sensor:
  - platform: version
    name: "Camera ESPHome Version"
    
switch:
  - platform: restart
    name: "Camera Restart"
    
binary_sensor:
  - platform: status
    name: "Camera Status"
    
sensor:
  - platform: uptime
    name: Uptime Sensor
  - platform: wifi_signal
    name: "Camera WiFi Signal Sensor"
    update_interval: 60s

Bonjour,
Je ne sais pas si ça vas t’aider mais ton gateway est bien 10.0.0.1?
Je suis pas trop calé en informatique, mais se ne devrais pas être l’adresse de ta box,? 192.168.x.x
Stefan

je ne sais pas, steffleur, c’est ce que j’avais renseigné lorsque cela fonctionnait sur l’ancienne version de Home Assistant.
Et d’ailleurs ne trouvant aucune solution j’ai réinstallé l’ancienne version haos_rpi4-64-6.0.rc1.img en lieu et place de la nouvelle haos_rpi4-64-6.1.img et cela refonctionne.

bonjour
as tu un routeur ou c’est ta box qui fourni les adresse ip .
effectivement si ca marche. c’est étrange.
par contre tu ne bénéficie pas des améliorations de HA en attendant , et ca c’est dommage.
stefan

bonjour,
j’ai une box de telenet qui fourni les adresse ip.
j’attendrai une autre version de HA pour refaire un essai.
A+