Forum Francophone Home Assistant

Gateway Aqara EU et alarme

Bonjour,
Je suis nouveau et je ne sais pas où poser ma question. Si ce n’est pas le bon endroit, merci de déplacer mon sujet ou de me dire ou le recréer.
Je suis sous hassio avec une clé conbee2.
J’ai aussi une passerelle Xiaomi Aqara EU sur serveur FR que j’ai réussi à intégrer avec HomeKit.
J’ai transférer 90% de mes équipements xiaomi/aqara sur ZHA à l’exception de mes caméras et mes prise wifi xiaomi qui sont toujours sur ma passerelle Aqara mais remontent bien dans HA.
Aujourd’hui, j’ai laissé mes capteurs d’ouverture sur ma passerelle Aqara afin qu’ils puissent déclencher l’alarme car je ne sais pas comment faire une fois que je les aurais intégrés dans ZHA pour qu’ils déclenchent l’alarme et aussi pour choisir et régler la sonnerie de la gateway aqara.
J’ai vu des tutos pour intégrer la passerelle aqara via le configuration.yaml avec le code ci-dessous mais je n’ai pas l’impression que cela fonctionne:
xiaomi_aqara:
discovery_retry: 5
gateways:
- mac: 50:EC:xx:xx:xx:xx
key: xxxxxxxxxxx

Pourtant j’ai bien les services comme « xiaomi_aqara.play_ringtone » mais impossible de faire sonner la sirène déjà. J’ai le message « Echec d’appel du service … »

Je voudrais pouvoir intégrer cette passerelle afin de m’en servir comme sirène/alarme et m’affranchir complètement du cloud xiaomi et de Homekit sous HA.

Merci à tous ceux qui pourront m’aider.

bonsoir
si tu veux juste l’utiliser comme avertisseur sonore ou lumineux.
utilise l’intégration xiaomi miio.
1 des 3 de l’exemple. mais les fonctions reste les mêmes.
les deux autres sont en xiaomi gateway (avec les capteur et actionneurs)
un exemple:
le script pour mon alarme:

alias: alarm
sequence:
  - service: xiaomi_aqara.play_ringtone
    data:
      ringtone_id: 1
      ringtone_vol: 100
      gw_mac: 'xx:xx:xx:xx:xx'
  - service: xiaomi_aqara.play_ringtone
    data:
      ringtone_id: 1
      ringtone_vol: 100
      gw_mac: 'XX:XX:XX:XX'
  - service: light.turn_on
    data:
      brightness: 130
      rgb_color:
        - 255
        - 0
        - 0
    entity_id: 'light.gateway_1, light.gateway_2, light.gateway_3'
  - delay: '2'
  - service: light.turn_on
    data:
      brightness: 130
      rgb_color:
        - 0
        - 0
        - 255
    entity_id: 'light.gateway_1, light.gateway_2, light.3'
  - delay: '2'
  - service: light.turn_on
    data:
      brightness: 130
      rgb_color:
        - 0
        - 255
        - 0
    entity_id: 'light.gateway_1, light.gateway_2, light.gateway_3'
  - delay: '2'
  - service: light.turn_off
    data: {}
    entity_id: >-
      light.gateway_light_XXXXXXX,light.gateway_light_XXXXXXX,light.xiaomi_gateway_light_XXXX
mode: single

la doc est ici

2 J'aimes

J’ai tenté comme tu me dis avec Xiaomi miio mais j’ai une erreur:

Logger: homeassistant.components.xiaomi_miio.gateway
Source: components/xiaomi_miio/gateway.py:46
Integration: Xiaomi Miio (documentation, issues)
First occurred: 21:40:26 (1 occurrences)
Last logged: 21:40:26

DeviceException during setup of xiaomi gateway with host 192.168.0.xxx

Est-ce que c’est parce qu’elle est déjà intégrée avec homekit?

Non , j’ai deux ha qui communique avec la même gateway, donc pas de soucis de ce côté, par contre as tu redémarrer, le serveur après avoir enlevé ta configurations manuel.
Pour home kit je ne connais pas

non j’ai fais l’intégration xiaomi miio tout de suite puis j’ai redémarré.
Tu penses que je dois supprimer l’intégration, rebooter sans et sans la config manuelle, puis refaire l’intégration?

Oui
Car c’est la même intégration donc en conflit si en Manu et auto et en homekit.tu aura peut être besoin de redémarrer une deuxième fois

idem même après 2 reboot

j’ai regarder la doc et les liens:
donc si j’ai compris:
1/ home kit te permet d’utiliser apple.
2/ l’integration miio xiaomi: tu n’auras pas accès au son sans modification que j’ai pas encor trouver:

accés

  • Gateway alarm control (Turn on/off; see status armed_away, disarmed, arming)
  • Gateway light control (Turn on/off; change brightness; change color; see status)
  • Gateway illuminance sensor readout (illuminance value in lux)

pas d’accés (but possible):

  • Gateway internet radio (only chinese stations)
  • Gateway ringtones/sounds

3/ l’integration gateway xiaomi te permet d’accéder à tous.
mais la methode d’integration est un peu différente.
il te faut l’adresse mac et ip, ainsi que le password lan (pas le token) ici

donc pour essayer je te conseil,
1/mettre des # devant ton intégration actuel. (l’integration manuel est certainement plus ancienne que l’intégration auto)

   # xiaomi_aqara:
   #   discovery_retry: 5
   #  gateways:
   #     - key: le_mot_de_passe_de_votre_passerelle

2/ redémarrer hassio
3/ configuration —> integration --------> + ----> xiaomi gateway aqua
puis laisser sur any et soumettre /// puis tu met ip mac code…
bon courage.
si ca ne vas pas tu décommente ton intégration.

La solution 3 je ne peux pas faire car ma gateway AQARA est une version EU donc je pense qu’elle n’est pas intégrable sur serveur chine et de ce fait je ne peux pas la passer en mode LAN (je crois que c’est pas possible sur cette version).
Donc il me reste comme solution la 2 dès que j’aurais fini de migrer mes derniers appareils qui sont encore sur MiHome vers ZHA. Par contre, ce qui me gène c’est que je ne pourrais pas faire sonner ma gateway en cas d’alarme !!! :thinking:

essaye quand m^éme, j’ai lu que sur iphone tu voie pas l’icone en bas , il faut donc taper plusieurs fois a l’aveugle en bas milieu d’écran.
pour faire apparaitre les menus.

 -cliquer sur la GW pour la sélectionner, c’est-à-dire « Mi Control Hub » (si le nom par défaut de l’appareil a été conservé)
 
 -cliquer sur les 3 points en haut à droite : “…”

-cliquer sur « About »

 **/!\ ATTENTION :** c’est maintenant le moment le plus délicat. Il s’agit d’activer le mode développeur.
 (A ce stade nmap -sU -p 9898 adrip renvoie 9898/udp closed)

 Sur cette page « About », sous Android il s’affiche un numéro de version sur lequel on clique mais ce numéro de version n’est pas visible sur iPhone. Avec un iPhone il faut cliquer en aveugle dans la zone blanche, 5 fois de suite rapidement et une nouvelle page apparaît avec plusieurs lignes écrites en chinois.
 Cliquer sur la ligne comportant 7 idéogrammes et activer le bouton switch pour qu’il passe au vert, cliquer le bouton « OK ».
 Cela active le mode développeur.
 (A ce stade nmap -sU -p 9898 adrip renvoie 9898/udp open)
 La clé API est indiquée (16 caractères Hexadécimales), la noter.


Le champ « Password » de l’équipement GW à renseigner correspond à la clé API de la GW notée précédemment.

 Configurer l’IP de la GW en DHCP statique.

source: https://community.jeedom.com/t/rtex-xiaomi-gateway-mode-dev-lan-et-port-udp-9898/46591 mais le principe est le même

Sauf que j’ai pas d’iphone. Je suis et j’ai toujours été sous android :sweat_smile:
J’ai utilisé Homekit juste pour intégrer ma passerelle dans HA avec la code Homekit qui est au cul de la gateway Aqara

ah ok
désoler .
as tu réussi?

oui j’ai réussi. mon seul soucis est de savoir comment faire sonner cette gateway maintenant

donc fait l’intégration Xiaomi Gateway aqua .

et après :
service :xiaomi_aqara.play_ringtone
data:

  gw_mac: xxxxxxxxxxxx
  ringtone_id: 2
  ringtone_vol: 100
1 J'aime

Bon j’ai fait plein de recherches et j’ai trouvé que les gateway xiaomi EU sont intégrables dans HA juste pour la lumière et armer/désarmer l’alarme. Par contre, impossible de les passer en mode LAN car on ne peut pas les mettre sur serveur CHINE alors impossible de récupérer la KEY. On ne peut donc pas gérer les sonneries via HA.
Si je veux garder cette gateway alors je dois garder MiHome pour la configurer au niveau des sonneries.

Ha mince. pourtant dans la doc il laisser l’espoir.

en cherchant ca doit être faisable
vite fais regarde par la. j’ai pas lu mais :"hack gateway eu home asssistant " semble une piste à suivre

J’ai finalement décidé de faire ma propre alarme manuelle avec des scripts et des automations, des MP3 joué sur ma sonos en attendant l’arrivée d’une sirène indépendante puissante.
J’ai un peu galéré mais tout fonctionne à merveille maintenant.

1 J'aime