Forum Francophone Home Assistant

Google assistant

Bonjour à tous,

J’essaye depuis 3 jours d’installer l’Add-on Google Assistant afin de commander via Google Home mini mes équipements.
J’ai suivi ce tuto : https://www.youtube.com/watch?v=fqi_p15eI8A&t=3343s, avec quelques manip qu’il faut adapter à cause des évolutions côté Google.
Ce qui coince :

  • impossible de valider le test lors de la création de l’action sous Google Action https://console.actions.google.com/
  • le log de l’addon Google SDK ne renvoi aucune erreur.
  • lors de l’association dans l’application Google Home, mon action [test] dit « associé » puis dans la foulé « une erreur est survenue, veuillez ré-essayer… »

J’ai tenté la réinstall plusieurs fois, mais c’est en boucle.

Si certain d’entre vous utilisent cet addon, avez vous un retour d’expérience sur des problèmes d’installation, ou des pistes a explorer, car le log ne me dit rien …

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[18:16:50] INFO: Installing/Updating service client_secrets file
[18:16:50] INFO: Starting WebUI for handling OAuth2…
[11/May/2020:18:16:51] ENGINE Listening for SIGTERM.
[11/May/2020:18:16:51] ENGINE Listening for SIGHUP.
[11/May/2020:18:16:51] ENGINE Listening for SIGUSR1.
[11/May/2020:18:16:51] ENGINE Bus STARTING
[11/May/2020:18:16:51] ENGINE Started monitor thread ‹ Autoreloader ›.
[11/May/2020:18:16:51] ENGINE Serving on http://0.0.0.0:9324
[11/May/2020:18:16:51] ENGINE Bus STARTED
[11/May/2020:18:17:14] ENGINE Bus STOPPING
[11/May/2020:18:17:14] ENGINE HTTP Server cherrypy._cpwsgi_server.CPWSGIServer((‹ 0.0.0.0 ›, 9324)) shut down
[11/May/2020:18:17:14] ENGINE Stopped thread ‹ Autoreloader ›.
[11/May/2020:18:17:14] ENGINE Bus STOPPED
[11/May/2020:18:17:14] ENGINE Bus EXITING
[11/May/2020:18:17:14] ENGINE Bus EXITED
[11/May/2020:18:17:14] ENGINE Waiting for child threads to terminate…
[18:17:14] INFO: Starting Home Assistant GAssisant SDK…

Ma config rpi4 + HA Core 0.109.3 sur ssd

Merci

J’ai réussi à interfacer HA et GH en suivant ce tuto : https://www.home-assistant.io/integrations/google_assistant/

Le pré-requis est que l’accès externe https soit en place, j’ai opté pour duckdns et let’s encrypt en suivant ce tuto : https://www.home-assistant.io/docs/configuration/remote/

2 J'aimes