Forum Francophone Home Assistant

HACS - Installation

Bonjour,

Bon, après avoir discuté de HACS ici :

Je me suis lancé dans l’installation de HACS pour Home Assistant Community Store.
En gros, un dépot d’intégration à base de plugins, réalisés par la communauté mais encore non reconnu officiellement par Home-Assistant.

Le lien officiel de HACS très bien fait, j’ai suivi la doc, pas de soucis particuliers, voire aucun.

Les pré-requis :

  • un HASS d’installé (surprenant…)
  • un accès à son HASS en SSH ou SAMBA
  • un compte github

Télécharger les fichiers HACS dans leur dernière version :
https://github.com/custom-components/hacs/releases/latest

Il est bien précisé de vérifier l’existence du dossier « .translations » avant d’aller plus loin.

Copier le dossier « hacs » sur votre hass (en SSH ou SAMBA) dans :

  • le répertoire « custom_components » à la racine de « config »
    SI vous utilisez hass sur un RPI, soit en mode hassio/docker, le chemin est :
  • /config/custom_components/hacs

Si « custom_components » n’existe pas, il faut le créer.

Redémarrer HASS

Sur votre compte GitHub :

  • Settings --> Developper settings
  • Personal Acces Tokens --> Generate new token
  • Donner un nom au token (exemple HACS)
  • Ne rien cocher --> cliquer sur generate
  • Copier le token

Depuis l’interface de votre HASS :

  • Configuration --> Integrations
  • cliquer sur le « + » en bas à droite
  • chercher HACS
  • cliquer sur HACS
  • coller le token
  • Side panel title : nom qui apparaitra dans le cadre de gauche
  • Side panel icon : icone du hacs souhaitée qui apparaitra avant le side panel title dans le cadre de gauche
  • Cocher AppDaemon
    –> pour savoir ce qu’est AppDaemon, c’est ici
    https://www.home-assistant.io/docs/ecosystem/appdaemon/

Ben je crois que c’est tout :wink:
Ce n’est pas tout à fait clic clic clic mais la barbe peut-être rasée de près.

Je ne peux pas encore vous en dire plus sur le catalogue, je n’ai pas tout testé ni regardé, mais vous vous ferez un avis par vous-même :wink:

Le petit test partagé par @pitp2

2 J'aimes

Merci pour ton partage d’expérience :slight_smile:

bonjour,

merci pour ton tuto,
j’ai pourtant un petit problème lors de l’installationn,
au moment de cliquer sur HACS pour ajouter l’intégration,
il reste bloqué sur « Veuillez patienter pendant que l’intégration est en cours d’installation »
j’ai bien vu sur le github qu’après 10mn ce n’était pas normal mais je ne vois pas ce qu’il se passe ?

je suis arrivé sur le token une fois en attendant très longtemps mais après l’avoir saisi c’est identique, ça tourne pendant des heures sans aller plus loin

dans les logs, je ne trouve rien de spécial a propos de hacs a part un warning qui me dit que c’est pas officiel …

alors une idée :interrobang:

Stéphane

Bonjour,

NON :wink: pas d’idées.

Mais il m’arrive aussi en cas de mise à jour que cela prenne du temps, alors j’ai pris le parti de redemarrer.
Mais j’avoue ne pas avoir réinstallé HACS depuis ce tuto.

Ce que je comprends c’est qu’il te trouve bien l’intégration HACS, mais pas moyen de l’ajouter
Je n’ai pas testé mais tu peux peut-etre l’ajouter manuellement dans le fichier de configuration, ca se tente :

bonne idée !

mais raté !

quand je met mon hacs: avec le token qui va bien derrière
je fais un ‹ VERIFIER LA CONFIGURATION › et la il se met a tourner en boucle sans arriver au bout, un peu de la même manière que lorsque je veut installer via les intégrations …

du coup je n’ai pas tenté de redémarrer, j’ai pas envie de tout perdre !!

je vais tenter de supprimer les fichiers et les re-télécharger et re-copier

[RESOLU]

bon,
j’ai supprimé tous les fichiers
re-téléchargé le zip
copié les fichiers en ligne de commande :

scp -P 23 -r ./hacs/ root@192.168.20.80:~/config/custom_components

rien de mieux qu’une bonne ligne de commande

l’installation a mis environ 2mn avant de demander la clé

bon y’a plus qu’à apprendre a maîtriser ce nouveau truc !!

2 J'aimes

Well done:-)
Tu prêches un convaincu pour la ligne de commande :slight_smile:

Tu vas vite le maîtriser :slight_smile: c’est un repository plein d addons :slight_smile:

Bonjour,
Voilà quelques heures que je bataille pour installer HACS.
J’ai bien transférer le dossier sur mon Raspberry, je l’ai redémarré, mais quand je veux l’ajouter dans les intégrations, il ne le trouve pas.
Une idée d’où peut venir mon problème ?

tu a bien resptecté les dossiers et sous dossiers ?
il doit être dans : config/custom_components/hacs
tous les fichiers et sous dossiers ici,
moi je voyais tout de même le composant même si il ne s’installait pas,
si il ne voit rien c’est peut être un mauvais nom de dossier …

Oui j’ai bien respecté les noms des dossiers.

EDIT:

Bon alors vue que je n’avais encore rien programmé d’important dans HA j’ai essayé de formater ma carte Sd et repartir de zéro pour installer, HACS.
J’ai procédé exactement de la même façon qu’avant pour l’installation, et cette fois ca a marché … Alors je ne saurais dire pourquoi.

2 J'aimes

les mystères de l’ouest … euh de HA :slight_smile:

Bon ben voila :wink: Well done

Mon HACS tourne en rond moi…

Bonjour bonjour

Mon HACS est toujours disabled :wink: Les grands mysteres de l’ouest

J’ai installé hier pour la troisième fois HA, mais cette fois sur une clé USB, donc cela devrait être plus stable que sur la MicroSD.
Et depuis HACS fonctionne très bien, et tout le reste aussi.