Forum Francophone Home Assistant

HTTPS et perte connection Local

Bonsoir,
J’utilise Duckdns en HTTPS pour me connecter en externe sur mon HA, et depuis je ne peux plus me connecter en local.
Avec l’adresse IP ca ne fonctionne plus, sauf si j’utilise l’adresse https://192.168.0.XX:8123, mais j’ai alors un message du aux problème de certificat SSL.

Comment faire pour retrouver ma connexion en local fonctionnel ?

Bonsoir,

Mais c’est bien cela ton adresse IP en local.

Bonsoir
À mes débuts de HA j’ai eu les mêmes soucis
Connexion parfaite en ssl externe mais plus de connexion interne ce qui pose de gros problèmes en cas de coupure internet
Je n’ai jamais trouvé de solution et j’ai même vu que c’était normal…
Du coup j’ai abandonné le ssl pour le moment

Alors je suis éventuellement prêt à m’y remettre si une solution est possible…

J’ai lu aussi sur les forum que c’était normal, et pour l’instant la seule solution que j’ai trouvé pour avoir le SSL et la connexion en local qui fonctionne bien c’est de prendre l’abonnement Nabu Casa.

Bonjour Messieurs,

Je ne comprends pas où cela bloque chez vous.
En fait vous voudriez utiliser la même URL depuis l’exterieur et en local ? C’est cela ?

De base on peut se connecter à notre HA avec son IP local.
Mais une fois que je paramètre la connection avec SSL pour me connecter depuis l’extérieur via DuckDns, il y a plus que cette adresse qui fonctionne, plus celle de l’adresse IP en local.

:+1:
Exactement :
sans le ssl, je me connectre depuis : homeassistant.local:8123, 192.168.20.80:8123, moncompte.duckdns.org:8123
avec ssl, je peut me connecter en https://moncompte.duckdns.org:8123
mais mon adresse https://192.168.20.80:8123 ne fonctionne plus
tout le problème est là … tu n’a pas le même souci chez toi @pepite ?

Si tu as AdGuard tu fais un fake dns…

J’ai vue des réponses sur certains forum qui parlé d’AdGuard.
Tu peux détailler ?

Bonjour,

@Stridel En fait non, car lorsque je suis sur mon LAN, je passe souvent par l’adresse IP interne par habitude.

Sinon c’est un comportement normal en fait, ca s’appelle le « Loopback » .
C’est en fait la possibilité, depuis ton réseau LAN d’atteindre une ressource de ton LAN (comme HA par exemple) en passant par l’exterieur en utilisant l’IP WAN(publique) du routeur pour atteindre l’équipement concerné.
En gros faire de chez soi, comme si on était à extérieur

Suis en WIFI -IP LAN --> URL HA DUCKDNS - IP WAN (depuis lexterieur) --> HA à la maison - IP LAN

Les box des FAI n’en font pas par défaut en général.

Essaie, d’après ce que tu nous donnes comme url,
Sur ta box :

  • fixe l’adresse IP de ton HA : 192.168.20.80
  • forward pour ton HA :
    –> port interne : 8123
    –> port externe : 8123

J’oubliais, @Canaletto te propse de creer un dns menteur, c’est-a-dire de faire croire que lorsque tu es à la maison, en fait tu es à l’exterieur pour pouvoir faire ce loopback

Pour être plus précis : paramètres de récriture DNS sous AdGuard.

monha.mondomaine.tld 192.168.1.x

Ca résout le pb quand on a pas de loopnack et en attendant que HA se penche sur le soucis. Autre piste utiliser un reverse proxy pour gérer le ssl, mais le pb sera identique.

@Canaletto tu l’utilises sur ton telephone AdGuard ?

Je parle de AdGuard en tant qu’addon HA qui est un serveur DNS amélioré…

Donc quand je suis chez moi mon tel passe par ce DNS

ah merci, je ne savais pas que cela existait en addon HA, je le connais à installer en tant que serveur

Je vais essayer l’addon alors :wink: par curiosité.

@steph96

Comme @Canaletto le précisait, j’ai testé ADGuard, c’est simple.
Je me suis demande s’il existait d’autres addons officiels.
Il existe aussi DNSmasq, très simple a configurer avec l’option host dans sa configuration

HAVE FUN

1 J'aime

Il y a d’autres projets, mais après en avoir testé d’autres AdGuard à ma préférence

2 J'aimes