Forum Francophone Home Assistant

Installation

Bonjour bonjour,

J’enchaine les outils qui pourraient être utilies, Node-Red a l’air d’en être un afin d’éviter d’avoir à modifier automations.yaml directement. Ca laisse le chox à chacun/

  • Ouvrez votre interface HA (Home Assistant)

  • Cliquez sur « hass.io » dans le cadre de gauche

  • Onglet ADD-ON STORE

  • chercher Node-Red

  • cliquer sur « Install »

  • Une fois l’installation terminée, allez dans le paragraphe « Config » en bas de page de l’add-on
  • Modifier « credential_secret » avec un mot de passe personnel.
  • Sauvegarder et démarrer Node-Red, ca met un certain temps à s’initialiser.

  • Redémarrer votre HA
  • Node-Red apparait en raccourci dans le cadre de gauche
  • Cliquer dessus et hop une fenetre node-red apparait…ou pas :wink:

Chez moi au premier clic cela n’a pas fonctionné : Erreur « 502 Bad Gateway »
Un petit coup de google et k’ai trouvé cette manip de contournement qui a fonctionné pour moi :

  • Ouvrez un navigateur ou un onglet : tapez l’adresse:port spécifié dans « Config » de l’ADD-ON
    http://IP_de_votre_HA:1880

1880 : port par défaut configuré dans l’ADD-ON

Ouverture de l’url : ok

Ensuite j’ai pu ouvrir la page de Node-Red à partir de HA.

Have-Fun

C’est en effet un must have.

Concernant cette erreur je l’ai eu aussi mais je pense qu’il suffit d’être patient que les processus en arrière plan se terminent

2 J'aimes

Bonjour,

J’essai d’installer NODE RED.

Lorsque que je lance, j’ai le message


            Oops! Something went wrong.

We are so sorry, but something went terribly wrong when
starting or running this add-on.

Be sure to check the log above, line by line, for hints.

[cont-finish.d] 99-message.sh: exited 0.
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

Une idée ?

Merci

Bonjour,

tu es arrivé à l’installer et c’est au moment ou tu appuie sur « start » que tu as ce message ?

Bonjour pitp2,

J’ai réussi à l’installer, mais que je clique sur start sa plante.

D’accord.

Pourrais tu mettre à disposition le fichier de config stp ?
Est ce que tu as mis ssl à false ?

voici le fichier de config

credential_secret: rodolphe
dark_mode: false
http_node:
  username: ''
  password: ''
http_static:
  username: ''
  password: ''
ssl: true
certfile: fullchain.pem
keyfile: privkey.pem
require_ssl: false
system_packages: []
npm_packages: []
init_commands: []

A chaque modification faut-il redemarrer HA ?

Merci pour ton aide

c’est tout bon en ouvrant les yeux c’est mieux :relaxed:
ssl: true -> ssk: false

merci

1 J'aime

Super :grinning:

Il ne faut pas re démarrer HA pour les modifs que tu faisais.

Bonjour,
Lors de l’installation de Node-RED, le fichier Config n’apparaît pas en bas de la page d’installation et lorsque je le lance depuis la barre latérale de HA, le message « 502: Bad Gateway s’affiche » ?
Voici le log d’installation Node-RED où se produit l’erreur :

[cont-init.d] nginx.sh: executing…
[15:45:48] FATAL:
[15:45:48] FATAL: SSL has been enabled using the ‹ ssl › option,
[15:45:48] FATAL: this requires a SSL certificate file which is
[15:45:48] FATAL: configured using the ‹ certfile › option in the
[15:45:48] FATAL: add-on configuration.

Salut Ives,

je t’ai déjà vu passer sur le forum Lifdomus :wink:

Alors bien souvent ce message indique que le lancement n’est pas terminé.
Il faut attendre un peu :slight_smile:

Oui 'j’hante" le forum Lifedomus depuis six ans mais suite à la fin annoncée de la box en 2023 je teste d’autres alternatives !
:flushed: je n’avais pas vu l’onglet configuration au-dessus ; dans le tuto d’une ancienne version il était en bas de la page ! Je vais, de ce pas , m’auto flageller !

Ah mais non faut pas se faire du mal :wink: