Forum Francophone Home Assistant

Pip3 check home configuration

petite info:
j’avais des erreurs régulières mais qui n’empêcher pas mon ha de tourner.
puis j’ai installer l’addons check home configurateur.

il m’a donner une erreur du style

après quelque recherche sur forum anglais: je n’avais pas la version pip3

voici comment j’ai installer pip3:
dans config.yaml

shell_command:
  pipupdate: pip3 install 

si vous n’avez pas déjà un fichier shell_command.yaml
puis redémarrage du serveur.
après outil de développement—>service puis shell_command.pipupdate valider
ou shell_command.pipupdate puis dans service yaml pip3 install
la j’ai un doute sur ce que j’ai fais.
puis trois redémarrage plus tard .les deux autres m’ont fait très peur google account et hacs ne donner des erreur tout est redevenu normal puis plus d’erreurs.
tout ok et surtout plus aucun problème dans check home configuration.
effacement de la ligne dans configuration.yaml.
et redémarrage

Salut,

tu avais installé cela en mode geek :slight_smile: et donc pas via une image Hassio ?

si via une image hassio . enfin je crois c’était le conseillé pour rpi4 en usb a l’époque
peut être qu’il faudrait que je refasse mon Install, maintenant, ca a peut être évoluer.

Bonjour,

Tu avais installé à partir d’une image et tu n’avais pas pip3 ?
heuuuu

je ne sais pas ce qu’est pip3 ( et l’erreur et sur quelque chose qui s’appel idna) mais bon dans le liens, du post initiale, on voie bien que la personne conseil d’installer pip3, puis tout est réglé.
et c’est vraie plus de soucis sur mon rpi4 (Hassio maitre) et plusieurs redémarrages qui m’ont fait flipper.
voici la version installer.5.4 à l’époque.
le problème viens peut être d’ici:
j’ai donc relu le tuto pour le rpi4 sur sdd et la j’ai vue qu’il y avais pas mal de changement.
a savoir qu’il déconseille les versions:

WARNING: Do NOT use HA OS 5.4! There was an issue with that version that affected some but not all RPi4s. (See discussions below.) Also do NOT use HA OS version 5.6 to 5.8. These contained their own boot EEPROM update code that flashed a beta version into the EEPROM. This approach was removed in 5.9.