Forum Francophone Home Assistant

Problèmes sensor

J’ai ca dans mon fichier config
config yaml

et j’ai créer mon config/sensors.yaml

Et HA me sort une erreur ligne 35 dans config

Bonjour
Essayez déjà de placer votre
sensor: ! Include avec les autres include
Group automation script etc
Puis créez un fichier sensor.yaml au même niveau que configuration.yaml pour mettre vos sensor.


Stefan

Aucune formule de politesse
Aucune question

@steffleur : j’admire ton dévouement :+1: :heart_eyes:

1 J'aime

Oui, j’avoue le problème vas Être difficile à résoudre avec ses hypothèses.
Mais bon a l’habitude.
je n’ais pas trop de temps pour finir mon aide au débutants. Qui est trop a ma vision et pas assez ouvert à tous.
Et pas de vacances avant août 2022.
Stefan

Je n’ai pas tout compris, j’essaye d’apprendre mais ca fait des heures et des heures que je lis des forums, des tuto francais, anglais… sans forcement m’en sortir

Merci d’avoir pris le temps de répondre.

La seule façon de m’en sortir avec les sensors ecocompteur à été de l’intégrer direct dans config.yaml, impossible, dès que je fais un include, ca ne marche pas

:+1:


Revenons en à la source :

En fait, le fait de mettre des !include XXX indique simplement au serveur de mettre le contenu à cet endroit.

Donc la ligner 35 se trouve dans un des fichiers inclus (comme on ne connait pas le nombre de lignes dans chacun, on ne peut pas le savoir, même si cela semble être le sensors.yaml d’après ton dernier commentaire).

Partage ton code qui fonctionne. et celui qui ne fonctionne pas…

Le forum est là pour aider, mais il faut y mettre à minima la forme (Bonjour, question, merci) :wink:

erreur de ma part, erreur ligne 25 du fichier config. Oui, une ligne vide

ca marche si tout est dans le fichier config comme ca :

Si je sors tout dans un fichier sensor.yaml, il me trouve une erreur dans la ligne 20 du fichier config :

Invalid config for [sensor]: required key not provided @ data[‹ platform ›]. Got None. (See /config/configuration.yaml, line 20).

Sans titre2

Pourtant j’ai mon fichier sensor.yaml

Bonjour
Si tu utilise sensor: !include sensor.yaml dans ton configuration.yaml
Tu n’as plus besoin de marquer dans le fichier sensor.yaml
Au début sensor: puisque c’est le nom du fichier.(ha sera que les sensor sont dans ce fichier)
Tu met directement

- plateform: command_line`
.......
- plateform:  command_line`
.......
- plateform: command_line`
.......

Et voilà en utilisant les includes tu vas gagner en lisibilité.

Stefan

bon bah en effet, c’etait juste ca. J’aurai pu chercher un moment vu qu’il me remontait une erreur dans le fichier config.

un point de réglé, merci.

celui la ne m’empêchait pas d’avancer, on va passer au chose sérieuse maintenant, démarrage sur SSD, réussir à finir d’installer samba